Rechercher sur ce site...

Mois : décembre 2016

Comprendre & configurer GNS3 correctement.

Comprendre :

Si je reprend le wiki: GNS3 (Graphical Network Simulator) est un logiciel libre permettant l'émulation ou la simulation de réseaux informatiques.

Explication:

GNS3  qui est l'équivalent de packet tracer de Cisco, a été conçu pour pallier à certaine limitation de packet tracer.  En effet, toutes les commandes ne sont pas présentes dans Packet Tracer.

Si vous souhaitez simplement tester la communication de machine virtuelle avec Wireshark à travers un hyperviseur de niveau 2 comme VMware ou VBox, vous n'avez pas besoin de GNS3. Parcontre, si vous souhaitez comprendre le fonctionnement des routeurs Cisco comme approfondir les protocoles de routage, etc..., ces deux outils sont adaptés pour cet apprentissage. Cependant, même s'ils permettent sensiblement de faire la même chose, ils ont une différence de taille; contrairement à Packet Tracert, GNS3 permet l'utilisation de machine virtuelle et un raccordement au réseau réel.

"Il faut bien garder en mémoire le but dans lequel GNS3 a été créé."

Prérequis :

  • VMware installés et j'ai attribué les cartes réseaux VMnet comme ci-dessous.

  • Télécharger l'image de la machine virtuelle GNS3 et l'importer dans VMWare. Les deux cartes VMnet  sont  attribuées dans la machine virtuelle GNS3.
  • Une liste d'image IOS

1/ Choix du Serveur

Dans le menu Edit-> Preferences, renseigner GNS3 VMware server. En effet, ceci est du à une certaine instabilité de l'émulation des images IOS sous Windows. En faite, cette étape est primordiale.

 

2/Testes des Images IOS.

Ceci est une étape importante pour la mise en place de maquette, il faut s'assurer de la stabilité des images importées. Donc, on met en place une maquette simple mais efficace.

2-1/Importer une image IOS:

  1. Cliquer sur New Appliance Template
  2. Choisir l'option Add an IOS
  3. Cliquer sur OK

Ensuite, choisir l'option de faire fonctionner l'image IOS sur la machine virtuelle tournant dans GNS3.

2-2/Maquette:

  • 2 VPCS
  • 2 Routeur pour simuler le comportement d'une box
  • 1 Routeur pour recevoir les pings
  • 1 Switch

Dans cet exemple, les PC1 et 2 sont respectivement derrière une box et ping le routeur R1 à l'adresse 192.168.254.254.

Avant de commancer, pour mieux apprécier le schéma, dans le menu View, cocher les options :

  • Snap to grid
  • Show the grid

Mettre en place les éléments et les nommer correctement. Lors de la mise en place de l'EtherSwitch, il est demandé sur quel machine souhaitez vous la faire fonctionner, naturellement, choisissez GNS3 VM.

2-3/Configuration & Test

Raccorder les machines et enfin démarrer l'ensemble. Si vous avez mis le maximum de coeur pour la VM GNS3, le CPU est sollicité à 100%. Double cliquer sur tous les routeurs et vérifier qu'ils ont tous complètement booter. Ensuite clique droit sur L’icône du routeur et choisir Idle-PC. Un menu déroulant va apparaitre et choisir un des éléments signalé par un asterisk.

Entrer les commandes suivantes:

  • PCs
ip 192.168.0.1 192.168.0.254
save

BOX1

conf t
interface fa0/0
ip address 192.168.0.254 255.255.255.0
no shutdown
ip nat inside

interface fa0/1
ip address 192.168.254.1 255.255.255.0
no shutdown
ip nat outside

access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 deny any

ip nat inside source list 1 interface fastEthernet 0/1
ip route 0.0.0.0 0.0.0.0 192.168.254.254
exit
write memory
copy run start

BOX2

conf t

interface fa0/0
ip address 192.168.0.254 255.255.255.0
no shutdown
ip nat inside

interface fa0/1
ip address 192.168.254.2 255.255.255.0
no shutdown
ip nat outside

access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 deny any

ip nat inside source list 1 interface fastEthernet 0/1
ip route 0.0.0.0 0.0.0.0 192.168.254.254

exit
write memory
copy run start

R1

conf t

interface fa0/0
ip address 192.168.254.254 255.255.255.0
no shutdown

exit
exit
write memory
copy run start

On ouvre Wireshark sur la pâte reliant le switch et le routeur R1 et on lance un ping d'un des deux PCs pour vérifier que le NAT s’exécute correctement.

Enfin, on enregistre la maquette, ensuite, on ferme le document et on le ré-ouvre. Mise à part le problème de l'occupation du CPU à 100%, si le ping est correctement "natté", alors c'est que l'image est stable.

Compaq A900Presario

Je dispose d'un PC portable Compaq A900Presario. Je tiens à exposer les différents services et son utilisation au sein de mon réseau personnel. Debian y est installé et tourne en permanence sur ce matériel.

Son histoire ...

... d'avant

Ce pc qui appartenez à un copain à couté dans les 600€ neuf, je l'ai acquis pour moitié moins. C'est mon premier PC portable. A l’époque, je faisant un peu de MAO dans ma voiture, et j'avais besoin d'une alimentation universelle avec un branchement sur allume-cigare, et j'ai cramé la carte mère. Par chance, l'appareil était encore en garanti et HP ne demandait pas de facture.

... et d'aujourd'hui

Aujourd'hui, il tourne tranquillement sur son meuble. Cependant, comme la grille d'aération se bouche rapidement, je l'ai installé sur un support ventilé.

Évolution technique du Compaq A900Presario

J'ai installé le processeur Intel T8300 afin d'augmenter la puissance d’exécution de la machine. Il fut impératif de mettre à jour le bios à jour de la carte mère pour enlever la "whitelist" qui bloque le changement de la carte wifi. J'ai remplacé le lecteur CD pour mettre un deuxième disque dur de même capacité que celui en place et avoir un RAID1 opérationnel.

Tableau récapitulatif de la mise à niveau du matériel.

Processeur T2390 T8300
Fréquence du processeur 1,83GHz 2,4GHz
Quantité de mémoire vive 2024Mo 2024Mo
Capacité de stockage principal 160Go 2x750Go
Type de stockage principal 5400tr/mn 7200tr/min

Rôles :

  • Contrôleur de domaine - samba 4
  • Serveur Xivo/Asterisk
  • Serveur Deluge

 

Page suivante »